Yes, it works smoothly with SUPEE-6788 security patch.